GeometryElement Class

GeometryElement Class

Geometric representation of an element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBGeometryElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class GeometryElement : GeometryObject, 
	IEnumerable<GeometryObject>
Public Class GeometryElement
	Inherits GeometryObject
	Implements IEnumerable(Of GeometryObject)
public ref class GeometryElement : public GeometryObject, 
	IEnumerable<GeometryObject^>
type GeometryElement = 
    class
        inherit GeometryObject
        interface IEnumerable<GeometryObject>
    end

The GeometryElement type exposes the following members.

Properties
 NameDescription
Public propertyGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyMaterialElementElement describing the material from which this element is composed.
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodGetBoundingBoxRetrieves a box that encloses the geometry element.
Public methodGetEnumeratorReturns an enumerator that iterates through the collection.
Protected methodGetEnumeratorNGReturns an enumerator that iterates through the collection.
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetTransformedReturns a transformed copy of the geometry in this element.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.
See Also