CADLinkOptions.ViewId Property

CADLinkOptionsViewId Property

The id of the view to use as the link's reference view, if the reference view has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId ViewId { get; set; }
Public Property ViewId As ElementId
	Get
	Set
public:
property ElementId^ ViewId {
	ElementId^ get ();
	void set (ElementId^ value);
}
member ViewId : ElementId with get, set

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentNullException When setting this property: A non-optional argument was null
See Also