OverrideGraphicSettings.SetSurfaceBackgroundPatternColor Method

OverrideGraphicSettingsSetSurfaceBackgroundPatternColor Method

Sets the override color of the surface background pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public OverrideGraphicSettings SetSurfaceBackgroundPatternColor(
	Color color
)
Public Function SetSurfaceBackgroundPatternColor ( 
	color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceBackgroundPatternColor(
	Color^ color
)
member SetSurfaceBackgroundPatternColor : 
        color : Color -> OverrideGraphicSettings 

Parameters

color  Color
Value of the surface background color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also