TriangulatedShellComponent.GetVertex Method

TriangulatedShellComponentGetVertex Method

Returns the vertex with a given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ GetVertex(
	int vertexIndex
)
Public Function GetVertex ( 
	vertexIndex As Integer
) As XYZ
public:
XYZ^ GetVertex(
	int vertexIndex
)
member GetVertex : 
        vertexIndex : int -> XYZ 

Parameters

vertexIndex  Int32
The index of the vertex (between 0 and getVertexCount()-1, inclusive).

Return Value

XYZ
A copy of the requested vertex.
Exceptions
ExceptionCondition
ArgumentException vertexIndex is out of range.
See Also