Revit 2025.3 API
Triangulated |
This class represents a triangulated boundary component of a solid or a
triangulated connected component of a shell.

SystemObject
Autodesk.Revit.DBTriangulatedShellComponent
Autodesk.Revit.DBTriangulatedShellComponent
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The TriangulatedShellComponent type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsClosed | True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles). |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | TriangleCount | The number of triangles in the triangulation. |
![]() | VertexCount | The number of vertices in the triangulation. |

Name | Description | |
---|---|---|
![]() | Clear | Empties the contents of this TriangulatedShellComponent. |
![]() | Dispose | Releases all resources used by the TriangulatedShellComponent |
![]() | GetTriangle | Returns the triangle corresponding to the given index. |
![]() | GetVertex | Returns the vertex with a given index. |
![]() | GetVertices | Returns the vertices of the triangulation. |

The triangulation is "topologically connected" in the following sense:
if two triangles share an edge geometrically, then they share a single edge
topologically (i.e., they share two vertices defining the geometrically shared
edge).
See Also