AssemblyMemberDifferentType Class

AssemblyMemberDifferentType Class

The two assembly members being compared have different type
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAssemblyMemberDifference
    Autodesk.Revit.DBAssemblyMemberDifferentType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AssemblyMemberDifferentType : AssemblyMemberDifference
Public Class AssemblyMemberDifferentType
	Inherits AssemblyMemberDifference
public ref class AssemblyMemberDifferentType : public AssemblyMemberDifference
type AssemblyMemberDifferentType = 
    class
        inherit AssemblyMemberDifference
    end

The AssemblyMemberDifferentType type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AssemblyMemberDifference)
Public propertyTypeId1 Type id of the first assembly member
Public propertyTypeId2 Type id of the second assembly member
Top
Methods
 NameDescription
Public methodDispose
(Inherited from AssemblyMemberDifference)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also