Revit 2025.3 API
Schedule |
The ID of the field to calculate percentages of.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ScheduleFieldId PercentageOf { get; set; }
Public Property PercentageOf As ScheduleFieldId Get Set
public: property ScheduleFieldId^ PercentageOf { ScheduleFieldId^ get (); void set (ScheduleFieldId^ value); }
member PercentageOf : ScheduleFieldId with get, set
Property Value
ScheduleFieldIdThe ID of the field, or InvalidElementId.

Exception | Condition |
---|---|
ArgumentException | When setting this property: percentageOf is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages. -or- When setting this property: percentageOf would create a circular chain of references. |
ArgumentNullException | When setting this property: A non-optional argument was null |
InvalidOperationException | When setting this property: This ScheduleField is not a percentage field. |

A Percentage field calculates what percent of the total of another field each element represents. PercentageOf is the ID of the field used to calculate percentages. If PercentageOf is InvalidScheduleFieldId, no data is displayed.
Percentages can only be calculated for numeric fields. The Count field and other percentage fields cannot be used to calculate percentages.
See Also