ElementBinding Class

ElementBinding Class

A base class for all types of binding that attach to an element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBBinding
      Autodesk.Revit.DBElementBinding
        Autodesk.Revit.DBInstanceBinding
        Autodesk.Revit.DBTypeBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class ElementBinding : Binding
Public MustInherit Class ElementBinding
	Inherits Binding
public ref class ElementBinding abstract : public Binding
[<AbstractClassAttribute>]
type ElementBinding = 
    class
        inherit Binding
    end

The ElementBinding type exposes the following members.

Properties
 NameDescription
Public propertyCategoriesRetrieve or set the categories to which a parameter definition will be bound.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This base class provides methods that are common to all types of binding that work with elements.
See Also