InstanceBinding Class

InstanceBinding Class

The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBBinding
      Autodesk.Revit.DBElementBinding
        Autodesk.Revit.DBInstanceBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class InstanceBinding : ElementBinding
Public Class InstanceBinding
	Inherits ElementBinding
public ref class InstanceBinding : public ElementBinding
type InstanceBinding = 
    class
        inherit ElementBinding
    end

The InstanceBinding type exposes the following members.

Constructors
 NameDescription
Public methodInstanceBindingConstructs an empty instance binding.
Public methodInstanceBinding(CategorySet)Constructs an instance binding with the set of categories passed.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Top
Remarks
Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.
See Also