ConnectionInputPointInfo Class

ConnectionInputPointInfo Class

An object that holds description information about a connection input point
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureConnectionInputPointInfo

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ConnectionInputPointInfo : IDisposable
Public Class ConnectionInputPointInfo
	Implements IDisposable
public ref class ConnectionInputPointInfo : IDisposable
type ConnectionInputPointInfo = 
    class
        interface IDisposable
    end

The ConnectionInputPointInfo type exposes the following members.

Constructors
 NameDescription
Public methodConnectionInputPointInfo Construct a default input point.
Public methodConnectionInputPointInfo(String, Int32, String) Construct an input point info.
Top
Properties
 NameDescription
Public propertyInputMemberIndex A index of the input member to which the restriction applies.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyPointSelectionText A string used to select input point by some connections.
Public propertyRestrictionType A type of input point restriction.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ConnectionInputPointInfo
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also