ColorOptions Class

ColorOptions Class

A class providing access to color settings which affect the colors applied to specific views.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBColorOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ColorOptions : IDisposable
Public Class ColorOptions
	Implements IDisposable
public ref class ColorOptions : IDisposable
type ColorOptions = 
    class
        interface IDisposable
    end

The ColorOptions type exposes the following members.

Properties
 NameDescription
Public propertyAlertColor The color of the current canvas theme used to highlight elements when a special alert is required.
Public propertyBackgroundColor The background color of the current canvas theme applied to views.
Public propertyCalculatingColor The color of the current canvas theme used to render elements when some aspect of their properties is currently being recalculated.
Public propertyEditingColor The color of the current canvas theme used to render elements when editing.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyPreselectionColor The color of the current canvas theme used to highlight candidates for selection before they are selected.
Public propertySelectionColor The color of the current canvas theme used to highlight selected elements.
Public propertySelectionSemitransparent Indicates whether or not selections will be shown in a semi-transparent manner in current canvas theme.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ColorOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodStatic memberGetColorOptions Returns the current Revit instance's ColorOptions.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
ColorOptions are managed and stored along with other global application options and thus impact the application as a whole.
See Also