Revit 2025.3 API
Fabric |
The id of the Fabric Sheet Type for this element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId FabricSheetTypeId { get; set; }
Public Property FabricSheetTypeId As ElementId Get Set
public: property ElementId^ FabricSheetTypeId { ElementId^ get (); void set (ElementId^ value); }
member FabricSheetTypeId : ElementId with get, set
Property Value
ElementId
Exception | Condition |
---|---|
ArgumentException | When setting this property: fabricSheetTypeId is not a Fabric Sheet Type. |
ArgumentNullException | When setting this property: A non-optional argument was null |

Changing the value of this property causes change of MinorLapSplice and MajorLapSplice properties if needed
See Also