Document.SetDefaultFamilyTypeId Method

DocumentSetDefaultFamilyTypeId Method

Sets the default family type id for the given family category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetDefaultFamilyTypeId(
	ElementId familyCategoryId,
	ElementId familyTypeId
)
Public Sub SetDefaultFamilyTypeId ( 
	familyCategoryId As ElementId,
	familyTypeId As ElementId
)
public:
void SetDefaultFamilyTypeId(
	ElementId^ familyCategoryId, 
	ElementId^ familyTypeId
)
member SetDefaultFamilyTypeId : 
        familyCategoryId : ElementId * 
        familyTypeId : ElementId -> unit 

Parameters

familyCategoryId  ElementId
The family category id.
familyTypeId  ElementId
The default family type id.
Exceptions
ExceptionCondition
ArgumentException The family type id familyTypeId is invalid for the give family category familyCategoryId.
ArgumentNullException A non-optional argument was null
See Also