RebarShape.GetAllowed Method

RebarShapeGetAllowed Method

Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool GetAllowed(
	RebarBarType barType
)
Public Function GetAllowed ( 
	barType As RebarBarType
) As Boolean
public:
bool GetAllowed(
	RebarBarType^ barType
)
member GetAllowed : 
        barType : RebarBarType -> bool 

Parameters

barType  RebarBarType
A bar type in the same document as this shape.

Return Value

Boolean
True if this shape may be combined with this barType.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also