OverrideGraphicSettings.SetCutLinePatternId Method

OverrideGraphicSettingsSetCutLinePatternId Method

Sets the ElementId of the cut surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public OverrideGraphicSettings SetCutLinePatternId(
	ElementId linePatternId
)
Public Function SetCutLinePatternId ( 
	linePatternId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutLinePatternId(
	ElementId^ linePatternId
)
member SetCutLinePatternId : 
        linePatternId : ElementId -> OverrideGraphicSettings 

Parameters

linePatternId  ElementId
ElementId of the cut surface line pattern for the override. InvalidElementId means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also