Revit 2025.3 API
IOpen |
A method called when the conflict is happen during the model opening.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
OpenConflictResult OnOpenConflict( OpenConflictScenario scenario )
Function OnOpenConflict ( scenario As OpenConflictScenario ) As OpenConflictResult
OpenConflictResult OnOpenConflict( OpenConflictScenario scenario )
abstract OnOpenConflict : scenario : OpenConflictScenario -> OpenConflictResult
Parameters
- scenario OpenConflictScenario
- The scenario of the conflict.
Return Value
OpenConflictResultReturns the result to indicate whether to keep the unsynchronized change, or open the latest version or cancel the open action.
See Also