VisibleInViewFilter Class

VisibleInViewFilter Class

A quick filter that passes elements that are most likely visible in the given view.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBVisibleInViewFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class VisibleInViewFilter : ElementQuickFilter
Public Class VisibleInViewFilter
	Inherits ElementQuickFilter
public ref class VisibleInViewFilter : public ElementQuickFilter
type VisibleInViewFilter = 
    class
        inherit ElementQuickFilter
    end

The VisibleInViewFilter type exposes the following members.

Constructors
 NameDescription
Public methodVisibleInViewFilter(Document, ElementId) Constructs a new instance of a VisibleInViewFilter.
Public methodVisibleInViewFilter(Document, ElementId, Boolean) Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory. In some situations (for example, when the element geometry is not yet calculated for the input view) this filter may return true even though the element may not actually be visible when geometry is calculated.
See Also