Revit 2025.3 API
Element |
A base class for a type of filter that accepts or rejects elements based upon criteria.

SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementSlowFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ElementFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ElementFilter |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | PassesFilter(Element) | Applies the filter to a given element. |
![]() | PassesFilter(Document, ElementId) | Applies the filter to a given element. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also