ElementSlowFilter Class

ElementSlowFilter Class

A base class for a type of filter that operates on expanded elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementSlowFilter : ElementFilter
Public Class ElementSlowFilter
	Inherits ElementFilter
public ref class ElementSlowFilter : public ElementFilter
type ElementSlowFilter = 
    class
        inherit ElementFilter
    end

The ElementSlowFilter type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Top
Remarks
Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple slow filters with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded in order to evaluate against the criteria set by this filter.
See Also
Inheritance Hierarchy