Revit 2025.3 API
Element |
A base class for filters used to match elements which intersect with geometry.

SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsElementFilter
Autodesk.Revit.DBElementIntersectsSolidFilter
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsElementFilter
Autodesk.Revit.DBElementIntersectsSolidFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ElementIntersectsFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | Inverted |
True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected,
and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter) |
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ElementFilter) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() ![]() | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters. |
![]() ![]() | IsElementSupported | Identifies if the input element is supported by element intersection filters. |
![]() | PassesFilter(Element) |
Applies the filter to a given element.
(Inherited from ElementFilter) |
![]() | PassesFilter(Document, ElementId) |
Applies the filter to a given element.
(Inherited from ElementFilter) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also