Revit 2025.3 API
Element |
A base class for filters used to match elements which intersect with geometry.

SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsElementFilter
Autodesk.Revit.DBElementIntersectsSolidFilter
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsElementFilter
Autodesk.Revit.DBElementIntersectsSolidFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ElementIntersectsFilter type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() ![]() | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters. |
![]() ![]() | IsElementSupported | Identifies if the input element is supported by element intersection filters. |
See Also