ElementIntersectsElementFilter Class

ElementIntersectsElementFilter Class

A filter to find elements that intersect the solid geometry of a given element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DBElementIntersectsFilter
        Autodesk.Revit.DBElementIntersectsElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementIntersectsElementFilter : ElementIntersectsFilter
Public Class ElementIntersectsElementFilter
	Inherits ElementIntersectsFilter
public ref class ElementIntersectsElementFilter : public ElementIntersectsFilter
type ElementIntersectsElementFilter = 
    class
        inherit ElementIntersectsFilter
    end

The ElementIntersectsElementFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementIntersectsElementFilter(Element) Constructs a filter to match elements which intersect the given element.
Public methodElementIntersectsElementFilter(Element, Boolean) Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetElement Gets the target element.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

The target object is another element. The intersection is determined with the same logic used by Revit to determine if an interference exists during generation of an Interference Report. (This means that some combinations of elements will never be detected as intersecting by this filter, such as concrete members which are automatically joined at their intersections). Also, elements which have no solid geometry, such as Rebar, will never be detected as intersecting by this filter.

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

See Also