ElementIntersectsElementFilter(Element) Constructor

ElementIntersectsElementFilter(Element) Constructor

Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementIntersectsElementFilter(
	Element element
)
Public Sub New ( 
	element As Element
)
public:
ElementIntersectsElementFilter(
	Element^ element
)
new : 
        element : Element -> ElementIntersectsElementFilter

Parameters

element  Element
The element to check for intersection.
Exceptions
ExceptionCondition
ArgumentException The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
ArgumentNullException A non-optional argument was null
See Also