Revit 2025.3 API
Structural |
A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.

SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DB.StructureStructuralInstanceUsageFilter
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DB.StructureStructuralInstanceUsageFilter
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The StructuralInstanceUsageFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | StructuralInstanceUsageFilter(StructuralInstanceUsage) | Constructs a new instance of a filter to match structural family instances (typically columns, beams, or braces) of the given structural usage. |
![]() | StructuralInstanceUsageFilter(StructuralInstanceUsage, Boolean) | Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage. |

Name | Description | |
---|---|---|
![]() | StructuralUsage | The family instance structural usage. |

Name | Description | |
---|---|---|

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements
before the elements are obtained and expanded. Therefore this filter does not have to be
paired with another quick filter to minimize the number of Elements that are expanded.
See Also