Revit 2025.3 API
Structural |
A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.

SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DB.StructureStructuralInstanceUsageFilter
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DB.StructureStructuralInstanceUsageFilter
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The StructuralInstanceUsageFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | StructuralInstanceUsageFilter(StructuralInstanceUsage) | Constructs a new instance of a filter to match structural family instances (typically columns, beams, or braces) of the given structural usage. |
![]() | StructuralInstanceUsageFilter(StructuralInstanceUsage, Boolean) | Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage. |

Name | Description | |
---|---|---|
![]() | Inverted |
True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected,
and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter) |
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter) |
![]() | StructuralUsage | The family instance structural usage. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ElementFilter) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | PassesFilter(Element) |
Applies the filter to a given element.
(Inherited from ElementFilter) |
![]() | PassesFilter(Document, ElementId) |
Applies the filter to a given element.
(Inherited from ElementFilter) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements
before the elements are obtained and expanded. Therefore this filter does not have to be
paired with another quick filter to minimize the number of Elements that are expanded.
See Also