StructuralInstanceUsageFilter(StructuralInstanceUsage, Boolean) Constructor

StructuralInstanceUsageFilter(StructuralInstanceUsage, Boolean) Constructor

Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public StructuralInstanceUsageFilter(
	StructuralInstanceUsage structuralUsage,
	bool inverted
)
Public Sub New ( 
	structuralUsage As StructuralInstanceUsage,
	inverted As Boolean
)
public:
StructuralInstanceUsageFilter(
	StructuralInstanceUsage structuralUsage, 
	bool inverted
)
new : 
        structuralUsage : StructuralInstanceUsage * 
        inverted : bool -> StructuralInstanceUsageFilter

Parameters

structuralUsage  StructuralInstanceUsage
The structural usage to match.
inverted  Boolean
True if the filter should match all family instances which are not of the given structural usage.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also