ElementPhaseStatusFilter Class

ElementPhaseStatusFilter Class

A filter used to match elements that have a given phase status on a given phase.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DBElementPhaseStatusFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementPhaseStatusFilter : ElementSlowFilter
Public Class ElementPhaseStatusFilter
	Inherits ElementSlowFilter
public ref class ElementPhaseStatusFilter : public ElementSlowFilter
type ElementPhaseStatusFilter = 
    class
        inherit ElementSlowFilter
    end

The ElementPhaseStatusFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public methodElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus)Initializes a new instance of the ElementPhaseStatusFilter class
Public methodElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public methodElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus, Boolean)Initializes a new instance of the ElementPhaseStatusFilter class
Top
Properties
 NameDescription
Public propertyPhaseId The phase id.
Top
Methods
 NameDescription
Public methodGetPhaseStatuses Returns the phase statuses assigned to this filter.
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also