ElementPhaseStatusFilter Class

ElementPhaseStatusFilter Class

A filter used to match elements that have a given phase status on a given phase.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DBElementPhaseStatusFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementPhaseStatusFilter : ElementSlowFilter
Public Class ElementPhaseStatusFilter
	Inherits ElementSlowFilter
public ref class ElementPhaseStatusFilter : public ElementSlowFilter
type ElementPhaseStatusFilter = 
    class
        inherit ElementSlowFilter
    end

The ElementPhaseStatusFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public methodElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus)Initializes a new instance of the ElementPhaseStatusFilter class
Public methodElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public methodElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus, Boolean)Initializes a new instance of the ElementPhaseStatusFilter class
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Public propertyPhaseId The phase id.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetPhaseStatuses Returns the phase statuses assigned to this filter.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also