ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) Constructor

ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) Constructor

Constructs a new instance of a file to match elements that have a given phase status on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementPhaseStatusFilter(
	ElementId phaseId,
	ElementOnPhaseStatus phaseStatus
)
Public Sub New ( 
	phaseId As ElementId,
	phaseStatus As ElementOnPhaseStatus
)
public:
ElementPhaseStatusFilter(
	ElementId^ phaseId, 
	ElementOnPhaseStatus phaseStatus
)
new : 
        phaseId : ElementId * 
        phaseStatus : ElementOnPhaseStatus -> ElementPhaseStatusFilter

Parameters

phaseId  ElementId
Id of the phase.
phaseStatus  ElementOnPhaseStatus
Target status.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also