PrimaryDesignOptionMemberFilter Class

PrimaryDesignOptionMemberFilter Class

A filter used to find elements contained in any primary design option of any design option set.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DBPrimaryDesignOptionMemberFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PrimaryDesignOptionMemberFilter : ElementSlowFilter
Public Class PrimaryDesignOptionMemberFilter
	Inherits ElementSlowFilter
public ref class PrimaryDesignOptionMemberFilter : public ElementSlowFilter
type PrimaryDesignOptionMemberFilter = 
    class
        inherit ElementSlowFilter
    end

The PrimaryDesignOptionMemberFilter type exposes the following members.

Constructors
 NameDescription
Public methodPrimaryDesignOptionMemberFilter Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public methodPrimaryDesignOptionMemberFilter(Boolean) Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter will only pass elements in a primary design option. It will not pass elements in the main model not associated to any design option. This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also