ElementLevelFilter Class

ElementLevelFilter Class

A filter used to match elements by their associated level.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DBElementLevelFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementLevelFilter : ElementSlowFilter
Public Class ElementLevelFilter
	Inherits ElementSlowFilter
public ref class ElementLevelFilter : public ElementSlowFilter
type ElementLevelFilter = 
    class
        inherit ElementSlowFilter
    end

The ElementLevelFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementLevelFilter(ElementId) Constructs a new instance of an ElementLevelFilter.
Public methodElementLevelFilter(ElementId, Boolean) Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Public propertyLevelId The id of the level that will be matched to elements' associated level.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also