CurveElementFilter Class

CurveElementFilter Class

A filter used to pass curve elements which are of a specific type.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DBCurveElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CurveElementFilter : ElementSlowFilter
Public Class CurveElementFilter
	Inherits ElementSlowFilter
public ref class CurveElementFilter : public ElementSlowFilter
type CurveElementFilter = 
    class
        inherit ElementSlowFilter
    end

The CurveElementFilter type exposes the following members.

Constructors
 NameDescription
Public methodCurveElementFilter(CurveElementType) Constructs a new instance of a filter to match specific types of curve elements.
Public methodCurveElementFilter(CurveElementType, Boolean) Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.
Top
Properties
 NameDescription
Public propertyCurveElementType The curve element type.
Top
Methods
 NameDescription
Top
See Also