StructuralWallUsageFilter Class

StructuralWallUsageFilter Class

A filter used to match walls that have the given structural wall usage.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DB.StructureStructuralWallUsageFilter

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class StructuralWallUsageFilter : ElementSlowFilter
Public Class StructuralWallUsageFilter
	Inherits ElementSlowFilter
public ref class StructuralWallUsageFilter : public ElementSlowFilter
type StructuralWallUsageFilter = 
    class
        inherit ElementSlowFilter
    end

The StructuralWallUsageFilter type exposes the following members.

Constructors
 NameDescription
Public methodStructuralWallUsageFilter(StructuralWallUsage) Constructs a new instance of a filter to match walls that have the given structural wall usage.
Public methodStructuralWallUsageFilter(StructuralWallUsage, Boolean) Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Public propertyStructuralWallUsage The wall structural usage.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
See Also