ViewSheet.Duplicate(SheetDuplicateOption) Method

ViewSheetDuplicate(SheetDuplicateOption) Method

Duplicates this sheet to generate a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId Duplicate(
	SheetDuplicateOption duplicateOption
)
Public Function Duplicate ( 
	duplicateOption As SheetDuplicateOption
) As ElementId
public:
ElementId^ Duplicate(
	SheetDuplicateOption duplicateOption
)
member Duplicate : 
        duplicateOption : SheetDuplicateOption -> ElementId 

Parameters

duplicateOption  SheetDuplicateOption
The option to use when duplicating the sheet.

Return Value

ElementId
The id of the newly created sheet.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Sheet cannot be duplicated
See Also