ViewSheet Class

ViewSheet Class

Class for ViewSheet
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBView
      Autodesk.Revit.DBViewSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewSheet : View
Public Class ViewSheet
	Inherits View
public ref class ViewSheet : public View
type ViewSheet = 
    class
        inherit View
    end

The ViewSheet type exposes the following members.

Properties
 NameDescription
Public propertyIsPlaceholder Identifies whether or not the view sheet represents a placeholder sheet.
Public propertySheetCollectionId The ID of the sheet collection this sheet is associated with.
Public propertySheetNumber The sheet number of the document.
Top
Methods
 NameDescription
Public methodCanBeDuplicated Identifies if this sheet can be duplicated.
Public methodConvertToRealSheet Converts a placeholder sheet to a real one with an optional titleblock.
Public methodStatic memberCreate Creates a new ViewSheet.
Public methodStatic memberCreatePlaceholder Creates a placeholder sheet in a document.
Public methodDeleteViewport Removes a viewport from the sheet by deleting it from the document.
Public methodDuplicate(SheetDuplicateOption) Duplicates this sheet to generate a new one.
Public methodGetAdditionalRevisionIds Gets the Revisions that are additionally included in the sheet's revision schedules.
Public methodGetAllPlacedViews Returns the ElementIds of Views placed on this sheet.
Public methodGetAllRevisionCloudIds Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Public methodGetAllRevisionIds Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Public methodGetAllViewports Returns the ElementIds of Viewports on this sheet.
Public methodGetCurrentRevision Returns the most recent numbered Revision shown on this ViewSheet.
Public methodGetRevisionCloudNumberOnSheet Gets the Revision Number for a RevisionCloud on this sheet.
Public methodGetRevisionNumberOnSheet Gets the Revision Number for a particular Revision as it will appear on this sheet.
Public methodSetAdditionalRevisionIds 
Top
See Also