ViewSheet Class

ViewSheet Class

Class for ViewSheet
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBView
      Autodesk.Revit.DBViewSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewSheet : View
Public Class ViewSheet
	Inherits View
public ref class ViewSheet : public View
type ViewSheet = 
    class
        inherit View
    end

The ViewSheet type exposes the following members.

Properties
 NameDescription
Public propertyAnalysisDisplayStyleId Element id of Analysis Display Style associated with the view.
(Inherited from View)
Public propertyAreAnalyticalModelCategoriesHidden Indicates if analytical model categories are currently hidden in the view.
(Inherited from View)
Public propertyAreAnnotationCategoriesHidden Indicates if annotation categories are currently hidden in the view.
(Inherited from View)
Public propertyAreCoordinationModelHandlesHidden Indicates if Coordination Model handles are currently hidden in the view.
(Inherited from View)
Public propertyAreImportCategoriesHidden Indicates if import categories are currently hidden in the view.
(Inherited from View)
Public propertyAreModelCategoriesHidden Indicates if model categories are currently hidden in the view.
(Inherited from View)
Public propertyArePointCloudsHidden Indicates if point clouds are currently hidden in the view.
(Inherited from View)
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyAssociatedAssemblyInstanceId The Id of the assembly instance that owns the assembly view.
(Inherited from View)
Public propertyBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCanBePrintedTest whether the view can be printed.
(Inherited from View)
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyCropBoxThe Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
(Inherited from View)
Public propertyCropBoxActiveWhether or not the Crop Box/Region is active for the view.
(Inherited from View)
Public propertyCropBoxVisibleWhether or not the Crop Box/Region is visible for the view.
(Inherited from View)
Public propertyDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDetailLevel The detail level of this view.
(Inherited from View)
Public propertyDiscipline The Discipline of the view.
(Inherited from View)
Public propertyDisplayStyle The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
(Inherited from View)
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyGenLevelThe level for the view.
(Inherited from View)
Public propertyGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIsAssemblyView Indicates if the view is assembly view.
(Inherited from View)
Public propertyIsCallout Indicates if the view is a callout view.
(Inherited from View)
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsPlaceholder Identifies whether or not the view sheet represents a placeholder sheet.
Public propertyIsTemplateTest whether the view is a view template.
(Inherited from View)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyOriginReturns the origin of the screen.
(Inherited from View)
Public propertyOutlineThe bounds of the view in paper space (in feet).
(Inherited from View)
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPartsVisibility The visibility setting for parts in this view.
(Inherited from View)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyRevealConstraintsMode Indicates whether the Reveal Constraints mode is activated in the view.
(Inherited from View)
Public propertyRightDirectionThe direction towards the right side of the screen.
(Inherited from View)
Public propertyScaleThe scale of the view.
(Inherited from View)
Public propertyShadowIntensity The intesity of cast shadows - 0 = no shadows, 100 = black.
(Inherited from View)
Public propertySheetCollectionId The ID of the sheet collection this sheet is associated with.
Public propertySheetNumber The sheet number of the document.
Public propertySketchPlaneThe sketch plane assigned to the view for model curve creation.
(Inherited from View)
Public propertySunAndShadowSettingsThe sun and shadow settings assigned to the view for shadow calculation and rendering.
(Inherited from View)
Public propertySunlightIntensity The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.
(Inherited from View)
Public propertyTemporaryViewModes Data of temporary view modes associated with this view.
(Inherited from View)
Public propertyTitle The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.
(Inherited from View)
Public propertyUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyUpDirectionThe direction towards the top of the screen.
(Inherited from View)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewDirectionThe direction towards the viewer.
(Inherited from View)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyViewTemplateId The id of the template view that controls this view's parameters.
(Inherited from View)
Public propertyViewTypeThe type of the view.
(Inherited from View)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodAddFilter Adds a filter to the view.
(Inherited from View)
Public methodAllowsAnalysisDisplay Identifies if this view allows display of Analysis results.
(Inherited from View)
Public methodApplyViewTemplateParameters Applies to this view the parameters of the input view that are not controlled by the current view template.
(Inherited from View)
Public methodAreGraphicsOverridesAllowed Determines if Visibility/Graphics Overriddes can be applied to the view.
(Inherited from View)
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanApplyColorFillScheme Checks if the id can be applied as the scheme id of specified category to this view.
(Inherited from View)
Public methodCanBeDuplicated Identifies if this sheet can be duplicated.
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanCategoryBeHidden Checks whether the category can be hidden in the view.
(Inherited from View)
Public methodCanCategoryBeHiddenTemporary Check if category can be temporarily hidden in the view.
(Inherited from View)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanEnableTemporaryViewPropertiesMode Indicates if Temporary View Properties mode can be applied for view in current state.
(Inherited from View)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodCanModifyDetailLevel Check if Detail Level can be modified.
(Inherited from View)
Public methodCanModifyDisplayStyle Indicates if DisplayStyle can be modified.
(Inherited from View)
Public methodCanModifyViewDiscipline Indicates if the View Discipline can be modified
(Inherited from View)
Public methodCanUseDepthCueing Indicates if view can use Depth Cueing
(Inherited from View)
Public methodCanUseTemporaryVisibilityModes Indicates if view can use temporary visibility modes
(Inherited from View)
Public methodCanViewBeDuplicated Identifies if this view can be duplicated.
(Inherited from View)
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodConvertTemporaryHideIsolateToPermanent Convert all temporary hidden elements or categories to permanently hidden in view.
(Inherited from View)
Public methodConvertToIndependent Convert the dependent view to independent.
(Inherited from View)
Public methodConvertToRealSheet Converts a placeholder sheet to a real one with an optional titleblock.
Public methodStatic memberCreate Creates a new ViewSheet.
Public methodStatic memberCreatePlaceholder Creates a placeholder sheet in a document.
Public methodCreateViewTemplate Creates a new view template instance from this view instance.
(Inherited from View)
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements
(Inherited from Element)
Public methodDeleteViewport Removes a viewport from the sheet by deleting it from the document.
Public methodDisableTemporaryViewMode Disables the specified temporary view mode.
(Inherited from View)
Public methodDispose
(Inherited from Element)
Public methodDuplicate(SheetDuplicateOption) Duplicates this sheet to generate a new one.
Public methodDuplicate(ViewDuplicateOption) Duplicates this view.
(Inherited from View)
Public methodEnableRevealHiddenMode Enables Reveal Hidden elements mode.
(Inherited from View)
Public methodEnableTemporaryViewPropertiesMode Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.
(Inherited from View)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues
(Inherited from Element)
Public methodGetAdditionalRevisionIds Gets the Revisions that are additionally included in the sheet's revision schedules.
Public methodGetAllPlacedViews Returns the ElementIds of Views placed on this sheet.
Public methodGetAllRevisionCloudIds Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Public methodGetAllRevisionIds Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Public methodGetAllViewports Returns the ElementIds of Viewports on this sheet.
Public methodGetBackground Returns the current background set for the view.
(Inherited from View)
Public methodGetCalloutParentId Gets ID of the callout parent view.
(Inherited from View)
Public methodGetCategoryHidden Checks if elements of the given category are set to be invisible (hidden) in this view.
(Inherited from View)
Public methodGetCategoryOverrides Gets graphic overrides for a category in view.
(Inherited from View)
Public methodGetColorFillSchemeId Returns id of the color fill scheme element applied to the view.
(Inherited from View)
Public methodGetCropRegionShapeManager Returns an object for managing view crop region shape.
(Inherited from View)
Public methodGetCurrentRevision Returns the most recent numbered Revision shown on this ViewSheet.
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetDependentViewIds Get the ids of dependent views.
(Inherited from View)
Public methodGetDepthCueing Returns the current depth cueing settings for the view.
(Inherited from View)
Public methodGetDirectContext3DHandleOverrides Returns DirectContext3D handle overrides object for the view.
(Inherited from View)
Public methodGetElementOverrides Gets graphic overrides for an element in the view.
(Inherited from View)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetFilterOverrides Gets graphic overrides that a filter applies to the view.
(Inherited from View)
Public methodGetFilters Gets the filters applied to the view.
(Inherited from View)
Public methodGetFilterVisibility Gets the visibility of the elements associated with a filter.
(Inherited from View)
Public methodGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetIsFilterEnabled Identifies if the filter is enabled in this view.
(Inherited from View)
Public methodGetLinkOverrides Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.
(Inherited from View)
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetModelToProjectionTransforms Gets the transforms from the model space to the view projection space.
(Inherited from View)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetNonControlledTemplateParameterIds Returns a list of parameters that are not marked as included when this view is used as a template.
(Inherited from View)
Public methodGetOrderedFilters Gets the filters applied to the view in the order they are applied.
(Inherited from View)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetPlacementOnSheetStatus Determines if this view placed on a sheet completely or partially.
(Inherited from View)
Public methodGetPointCloudOverrides Returns point cloud overrides object for the view.
(Inherited from View)
Public methodGetPrimaryViewId Get the id of the primary view.
(Inherited from View)
Public methodGetReferenceCallouts Returns element ids of all reference callouts in the view.
(Inherited from View)
Public methodGetReferenceElevations Returns element ids of all reference elevations in the view.
(Inherited from View)
Public methodGetReferenceSections Returns element ids of all reference sections in the view.
(Inherited from View)
Public methodGetRevisionCloudNumberOnSheet Gets the Revision Number for a RevisionCloud on this sheet.
Public methodGetRevisionNumberOnSheet Gets the Revision Number for a particular Revision as it will appear on this sheet.
Public methodGetSketchyLines Returns the current sketchy lines settings for the view.
(Inherited from View)
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTemplateParameterIds Returns a list of parameter ids that may be controlled when this view is assigned as a template.
(Inherited from View)
Public methodGetTemporaryViewPropertiesId When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.
(Inherited from View)
Public methodGetTemporaryViewPropertiesName When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.
(Inherited from View)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodGetViewDisplayModel Returns the current view display model settings for the view.
(Inherited from View)
Public methodGetWorksetVisibility Returns the visibility settings of a workset for this particular view.
(Inherited from View)
Public methodGetWorksharingDisplayMode Gets the current worksharing display mode for this view.
(Inherited from View)
Public methodHasDetailLevel Check if the view has a Detail Level property
(Inherited from View)
Public methodHasDisplayStyle Indicates if view has a DisplayStyle property
(Inherited from View)
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodHasViewDiscipline Indicates if the view has a Discipline property
(Inherited from View)
Public methodHasViewTransforms Returns true if the view reports model space to view projection space transforms.
(Inherited from View)
Public methodHideActiveWorkPlaneHide the active work plane of the view.
(Inherited from View)
Public methodHideCategoriesTemporary
(Inherited from View)
Public methodHideCategoryTemporary Set one category to be temporarily hidden in the view.
(Inherited from View)
Public methodHideElements
(Inherited from View)
Public methodHideElementsTemporary
(Inherited from View)
Public methodHideElementTemporary Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
(Inherited from View)
Public methodIsCategoryOverridable Checks whether the category can have graphic overrides in this view.
(Inherited from View)
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsElementVisibleInTemporaryViewMode Identifies if the input element is visible for the temporary view mode for this view.
(Inherited from View)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsFilterApplied Indicates if a filter is applied to the view.
(Inherited from View)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsInTemporaryViewMode Returns true if the view is in a particular temporary view mode.
(Inherited from View)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsolateCategoriesTemporary
(Inherited from View)
Public methodIsolateCategoryTemporary Set one category to be temporarily isolated in the view.
(Inherited from View)
Public methodIsolateElementsTemporary
(Inherited from View)
Public methodIsolateElementTemporary Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
(Inherited from View)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsTemporaryHideIsolateActive Indicates if the view is temporarily hiding or isolating elements or categories.
(Inherited from View)
Public methodIsTemporaryViewPropertiesModeEnabled Returns true when Temporary View Properties mode is in progress, false otherwise.
(Inherited from View)
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodIsValidViewTemplate Verifies that the view represented by templateId can be set as the controlling view template for this view.
(Inherited from View)
Public methodIsViewValidForTemplateCreation Verifies that the view is valid for template creation.
(Inherited from View)
Public methodIsWorksetVisible Indicates whether the workset is visible in this view.
(Inherited from View)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodPrintPrint this view with the default view template and using the print setting of the current active document.
(Inherited from View)
Public methodPrint(Boolean)Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
(Inherited from View)
Public methodPrint(View)Print this view with the given view template and using the print setting of the current active document.
(Inherited from View)
Public methodPrint(View, Boolean)Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
(Inherited from View)
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodRemoveCalloutParent Replaces callout parent ID with InvalidElementId.
(Inherited from View)
Public methodRemoveFilter Removes a filter from the view.
(Inherited from View)
Public methodRemoveLinkOverrides Deletes the graphical link overrides in the current view.
(Inherited from View)
Public methodRestoreCalloutParent Restores callout parent ID to the original view ID if that view is still available.
(Inherited from View)
Public methodSetAdditionalRevisionIds 
Public methodSetBackground Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.
(Inherited from View)
Public methodSetCategoryHidden Sets if elements of the given category will be visible in this view.
(Inherited from View)
Public methodSetCategoryOverrides Sets graphic overrides for a category in view.
(Inherited from View)
Public methodSetColorFillSchemeId Applies color fill scheme to this view.
(Inherited from View)
Public methodSetDepthCueing Sets the depth cueing settings for the view.
(Inherited from View)
Public methodSetElementOverrides Sets graphic overrides for an element in the view.
(Inherited from View)
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSetFilterOverrides Sets the overrides associated with a filter.
(Inherited from View)
Public methodSetFilterVisibility Sets the visibility of the elements associated with a filter.
(Inherited from View)
Public methodSetIsFilterEnabled Sets the filter enabled flag.
(Inherited from View)
Public methodSetLinkOverrides Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.
(Inherited from View)
Public methodSetNonControlledTemplateParameterIds
(Inherited from View)
Public methodSetSketchyLines Sets the sketchy lines settings for the view.
(Inherited from View)
Public methodSetViewDisplayModel Sets the view display model settings for the view.
(Inherited from View)
Public methodSetWorksetVisibility Sets visibility for a workset in this view.
(Inherited from View)
Public methodSetWorksharingDisplayMode Sets the worksharing display mode for this view.
(Inherited from View)
Public methodShowActiveWorkPlaneShow the active work plane of the view.
(Inherited from View)
Public methodSupportedColorFillCategoryIds Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type.
(Inherited from View)
Public methodSupportsRevealConstraints Checks that the view can have the Reveal Constraints mode activated.
(Inherited from View)
Public methodSupportsWorksharingDisplayMode Checks whether this view supports the given worksharing display mode.
(Inherited from View)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Public methodUnhideElements
(Inherited from View)
Top
See Also