View.GetLinkOverrides Method

ViewGetLinkOverrides Method

Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RevitLinkGraphicsSettings GetLinkOverrides(
	ElementId linkId
)
Public Function GetLinkOverrides ( 
	linkId As ElementId
) As RevitLinkGraphicsSettings
public:
RevitLinkGraphicsSettings^ GetLinkOverrides(
	ElementId^ linkId
)
member GetLinkOverrides : 
        linkId : ElementId -> RevitLinkGraphicsSettings 

Parameters

linkId  ElementId
The id of the RevitLinkType or RevitLinkInstance.

Return Value

RevitLinkGraphicsSettings
Settings representing graphic overrides for the input element id in the view, or if the input id references RevitLinkInstance and it doesn't have overrides in the view.
Exceptions
ExceptionCondition
ArgumentException The input id is not a valid RevitLinkInstance or RevitLinkType id.
ArgumentNullException A non-optional argument was null
See Also