Revit 2025.3 API
View |
Creates a placeholder sheet in a document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ViewSheet CreatePlaceholder( Document aDoc )
Public Shared Function CreatePlaceholder ( aDoc As Document ) As ViewSheet
public: static ViewSheet^ CreatePlaceholder( Document^ aDoc )
static member CreatePlaceholder : aDoc : Document -> ViewSheet
Parameters
- aDoc Document
- The document.
Return Value
ViewSheetThe placeholder sheet.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Placeholder sheets represent sheets stored outside of the Revit model,
but which should be organized along with the Revit sheets.
See Also