Revit 2025.3 API
View |
Gets the Revisions that are additionally included in the sheet's revision schedules.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ICollection<ElementId> GetAdditionalRevisionIds()
Public Function GetAdditionalRevisionIds As ICollection(Of ElementId)
public: ICollection<ElementId^>^ GetAdditionalRevisionIds()
member GetAdditionalRevisionIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementIdThe additionally included Revisions for the sheet's revision schedules.

Revisions in the sheet's additional project revisions set will appear in revisions schedules
even if no RevisionCloud belonging to that Revision is visible on the sheet.
These ids correspond to the Revisions that are explicitly included on the sheet via the
Revisions On Sheet parameter.
See Also