Reference.GlobalPoint Property

ReferenceGlobalPoint Property

The position on which the reference is hit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ GlobalPoint { get; }
Public ReadOnly Property GlobalPoint As XYZ
	Get
public:
property XYZ^ GlobalPoint {
	XYZ^ get ();
}
member GlobalPoint : XYZ with get

Return Value

XYZ
if the reference doesn't have a global point.
Remarks
When using a plan view, the Z-value of a GlobalPoint is not meaningful.
See Also