Reference Class

Reference Class

A stable reference to a geometric object in a Revit model.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Reference : APIObject
Public Class Reference
	Inherits APIObject
public ref class Reference : public APIObject
type Reference = 
    class
        inherit APIObject
    end

The Reference type exposes the following members.

Constructors
 NameDescription
Public methodReferenceCreates a Reference with the supplied element.
Top
Properties
 NameDescription
Public propertyElementIdThe element id for this reference.
Public propertyElementReferenceTypeThe type of reference.
Public propertyGlobalPointThe position on which the reference is hit.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyLinkedElementIdThe id of the top-level element in the linked document that is referred to by this reference.
Public propertyUVPointThe UV parameters of the reference, if the reference contains a face.
Top
Methods
 NameDescription
Public methodContainsChecks if given reference identifies part of object identified by this reference.
Public methodConvertToStableRepresentationConverts the reference to a stable String representation.
Public methodCreateLinkReferenceCreates a Reference from a Reference in an RVT Link.
Public methodCreateReferenceInLinkCreates a Reference in an RVT Link from a Reference in the RVT host file.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEqualToChecks if given reference is equal to this reference.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberParseFromStableRepresentationConverts a stable String representation of a reference to a Reference object.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also