DirectShapeType.IsValidShape(ExternallyTaggedGeometryObject) Method

DirectShapeTypeIsValidShape(ExternallyTaggedGeometryObject) Method

Validates shape to be stored in a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsValidShape(
	ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Function IsValidShape ( 
	externallyTaggedGeometry As ExternallyTaggedGeometryObject
) As Boolean
public:
bool IsValidShape(
	ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member IsValidShape : 
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool 

Parameters

externallyTaggedGeometry  ExternallyTaggedGeometryObject
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
This function uses the same criteria as IsValidShape(GeometryObject).
See Also