ExternalDefinitionCreationOptions.HideWhenNoValue Property

ExternalDefinitionCreationOptionsHideWhenNoValue Property

This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool HideWhenNoValue { get; set; }
Public Property HideWhenNoValue As Boolean
	Get
	Set
public:
property bool HideWhenNoValue {
	bool get ();
	void set (bool value);
}
member HideWhenNoValue : bool with get, set

Property Value

Boolean
True if the parameter should be hidden when it has no value, False if the parameter should remain visible in the properties palette even when it doesn't have a value. The default is false
See Also