ExternalDefinitionCreationOptions Class

ExternalDefinitionCreationOptions Class

An option class used for creating a new shared parameter definition, including options such as name, type, visibility, Guid description and modifiable flag.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalDefinitionCreationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ExternalDefinitionCreationOptions : IDisposable
Public Class ExternalDefinitionCreationOptions
	Implements IDisposable
public ref class ExternalDefinitionCreationOptions : IDisposable
type ExternalDefinitionCreationOptions = 
    class
        interface IDisposable
    end

The ExternalDefinitionCreationOptions type exposes the following members.

Constructors
 NameDescription
Public methodExternalDefinitionCreationOptions Constructs the options using a specified name and type.
Top
Properties
 NameDescription
Public propertyDescription The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.
Public propertyGUID The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.
Public propertyHideWhenNoValue This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The name of the parameter definition to be created.
Public propertyUserModifiable This property indicates whether this parameter can be modified by UI user or not.
Public propertyVisible True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExternalDefinitionCreationOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetDataType Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetDataType Sets the parameter's data type.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also