ExternalDefinitionCreationOptions.SetDataType Method

ExternalDefinitionCreationOptionsSetDataType Method

Sets the parameter's data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetDataType(
	ForgeTypeId dataType
)
Public Sub SetDataType ( 
	dataType As ForgeTypeId
)
public:
void SetDataType(
	ForgeTypeId^ dataType
)
member SetDataType : 
        dataType : ForgeTypeId -> unit 

Parameters

dataType  ForgeTypeId
The identifier of either a spec or a category. A category identifier indicates a Family Type parameter of that category.
Exceptions
ExceptionCondition
ArgumentException The given identifier is neither a spec nor a category.
ArgumentNullException A non-optional argument was null
See Also