RebarShape.GetDefaultHookOrientation Method

RebarShapeGetDefaultHookOrientation Method

Get the hook orientation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RebarHookOrientation GetDefaultHookOrientation(
	int index
)
Public Function GetDefaultHookOrientation ( 
	index As Integer
) As RebarHookOrientation
public:
RebarHookOrientation GetDefaultHookOrientation(
	int index
)
member GetDefaultHookOrientation : 
        index : int -> RebarHookOrientation 

Parameters

index  Int32
0 for the starting hook, 1 for the ending hook.

Return Value

RebarHookOrientation
Exceptions
ExceptionCondition
ArgumentOutOfRangeException index must be 0 or 1.
Remarks
Replaces the method GetHookOrientation() from prior releases.
See Also