MEPHiddenLineSettings.LineStyle Property

MEPHiddenLineSettingsLineStyle Property

The line style that determines how the lines of a hidden segment display at the point where the segments cross.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId LineStyle { get; set; }
Public Property LineStyle As ElementId
	Get
	Set
public:
property ElementId^ LineStyle {
	ElementId^ get ();
	void set (ElementId^ value);
}
member LineStyle : ElementId with get, set

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The line style is invalid for hidden line display.
ArgumentNullException When setting this property: A non-optional argument was null
See Also