BuiltInFailures.FormFailures Class

BuiltInFailuresFormFailures Class

Failures about Form.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresFormFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class FormFailures
Public NotInheritable Class FormFailures
public ref class FormFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormFailures = class end

The BuiltInFailuresFormFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAddProfileFailure Failed to Add Profile
Public propertyStatic memberDissolveNoValidInputs No form elements selected to dissolve.
Public propertyStatic memberDissolveUnableToDissolveForm Unable to dissolve form element.
Public propertyStatic memberFormCreationInvalidGeomCombination Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
Public propertyStatic memberFormElemRegenFailure Unable to create form element
Public propertyStatic memberFormElemRegenFailureError Unable to create form element
Public propertyStatic memberFormElemRegenSelfIntersection Unable to create form element: self-intersecting or singular geometry would result.
Public propertyStatic memberFormElemRegenSelfIntersectionReorderProfiles This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
Public propertyStatic memberFormElemRegenSelfIntersectionResetConnections This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
Public propertyStatic memberOpenProfileMultiSegmentSweepsNotSupported An open profile cannot be swept along a multi-segment path.
Public propertyStatic memberVoidFormsNotUsed Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.
Top
See Also