Revit 2025.3 API
Bounding |
Constructs a new instance of a filter to match elements with a bounding box that contains the given point,
while specifying the tolerance to be used in deciding if the point matches the criteria.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public BoundingBoxContainsPointFilter( XYZ point, double tolerance )
Public Sub New ( point As XYZ, tolerance As Double )
public: BoundingBoxContainsPointFilter( XYZ^ point, double tolerance )
new : point : XYZ * tolerance : float -> BoundingBoxContainsPointFilter
Parameters
- point XYZ
- The point used to find elements with a bounding box that contains it.
- tolerance Double
- The tolerance value to use instead of zero. See the tolerance property for details.

Exception | Condition |
---|---|
ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number |
ArgumentNullException | A non-optional argument was null |
See Also