Revit 2025.3 API
Phase |
Creates a new phase filter with default status presentation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static PhaseFilter Create( Document document, string name )
Public Shared Function Create ( document As Document, name As String ) As PhaseFilter
public: static PhaseFilter^ Create( Document^ document, String^ name )
static member Create : document : Document * name : string -> PhaseFilter
Parameters
- document Document
- The document.
- name String
- The name.
Return Value
PhaseFilterThe newly created phase filter.

Exception | Condition |
---|---|
ArgumentException | name is already in use. |
ArgumentNullException | A non-optional argument was null |

The default status presentation is ShowByCategory for New status, and ShowOverriden for Existing,
Demolished and Temporary statuses.
See Also