BuiltInFailures.PipingFailures Class

BuiltInFailuresPipingFailures Class

Failures about Pipes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresPipingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class PipingFailures
Public NotInheritable Class PipingFailures
public ref class PipingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PipingFailures = class end

The BuiltInFailuresPipingFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCannotCreateGeometryForPipe Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
Public propertyStatic memberCircularLoopInPipeSizing Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
Public propertyStatic memberDuctPipeModified The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
Public propertyStatic memberDuctPipeSizeMismatch The duct/pipe size is invalid for the service definition
Public propertyStatic memberFabFittingFailed The Fabrication Fitting was invalid
Public propertyStatic memberInvalidPipeSize Pipe Size Table "[File Name]" is missing or invalid.
Public propertyStatic memberMaxPipeSizeReached Maximum pipe size diameter reached during sizing
Public propertyStatic memberPartNotFoundDueToNoPipeConnectedError "In order to find a matching part, the fitting has to be connected to a pipe."
Public propertyStatic memberPartNotFoundDueToNoPipeConnectedWarning "In order to find a matching part, the fitting has to be connected to a pipe."
Public propertyStatic memberPartNotFoundInRoutingPreferenceError "%1s is not found. Please review the routing preference of %2s."
Public propertyStatic memberPartNotFoundInRoutingPreferenceWarning "%1s is not found. Please review the routing preference of %2s."
Top
See Also