XYZ.Division Operator

XYZDivision Operator

Divides the specified vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static XYZ operator /(
	XYZ left,
	double value
)
Public Shared Operator / ( 
	left As XYZ,
	value As Double
) As XYZ
public:
static XYZ^ operator /(
	XYZ^ left, 
	double value
)
static let inline (/)
        left : XYZ * 
        value : float  : XYZ

Parameters

left  XYZ
The value to divide the vector by.
value  Double
The vector to divide by the value.

Return Value

XYZ
The divided vector.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when source is .
ArgumentException Thrown when the specified value is an infinite number or zero.
Remarks
The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.
See Also