BuildingOperatingDaySchedule.ScheduleName Property

BuildingOperatingDayScheduleScheduleName Property

The name of the schedule.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string ScheduleName { get; set; }
Public Property ScheduleName As String
	Get
	Set
public:
property String^ ScheduleName {
	String^ get ();
	void set (String^ value);
}
member ScheduleName : string with get, set

Property Value

String
Exceptions
ExceptionCondition
ArgumentException When setting this property: name must not match an existing name, even with different case. -or- When setting this property: name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: name must be trimmed. -or- When setting this property: name is an empty string or contains only whitespace.
ArgumentNullException When setting this property: A non-optional argument was null
See Also