Revit 2025.3 API
Direct |
Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsValidUsage( ExternallyTaggedGeometryObject externallyTaggedGeometry )
Public Function IsValidUsage ( externallyTaggedGeometry As ExternallyTaggedGeometryObject ) As Boolean
public: bool IsValidUsage( ExternallyTaggedGeometryObject^ externallyTaggedGeometry )
member IsValidUsage : externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool
Parameters
- externallyTaggedGeometry ExternallyTaggedGeometryObject
- The geometry to check.
Return Value
BooleanTrue if the usage is permitted.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also